حفره امنیتی جدید و خطرناک MySQL، MariaDB و PerconaDB که به تازگی منتشر شده است.

وجود حفره‌های امنیتی در MySQL، MariaDB و PerconaDB این امکان را به هکر می‌دهد تا به سرور میزبان این پایگاه داده‌ها دسترسی داشته باشد. هکر با استفاده از این حفره‌های امنیتی می‌تواند کد مخرب خود را اجرا کرده و دسترسی مدیریتی به سرور داشته باشد.

آسیب‌پذیری‌ها نسخه‌های 5.5.51 و قبل‌تر، 5.6.32 و قبل‌تر و هم‌چنین 5.7.14 و قبل‌تر پایگاه داده MySQL و Percona و MariaDB را تحت تأثیر قرار داده است.

اولین آسیب‌پذیری با کد CVE-2016-6663 شناخته می‌شود که یک آسیب‌پذیری افزایش سطح دسترسی است و امکان اجرای کد را به هکر می‌دهد. بدین ترتیب با یک حساب کاربری سطح پایین می‌توان کدهای مخرب را اجرا کرد. البته این آسیب‌پذیری می‌تواند در کنار آسیب‌پذیری‌های افزایش سطح دسترسی قدیمی‌تر با کد CVE-2016-6662 و CVE-2016-6664، که در ماه سپتامبر عمومی شد، به کار گرفته شود.
دومین آسیب‌پذیری افزایش سطح دسترسی به سطح مدیریت است که با کد CVE-2016-6663 شناخته می‌شود. با استفاده از این آسیب‌پذیری هکر می‌تواند سطح اجرای کدهای خود را تا سطح مدیریت ارتقاء دهد. هکر با استفاده از error.log می‌تواند کدهای مخرب خود را اجرا کند.

لینک اکسپلویت ها :

MySQL / MariaDB / PerconaDB 5.5.x/5.6.x/5.7.x 'mysql' System User Privilege Escalation Vulnerability

MySQL / MariaDB / PerconaDB 5.5.x/5.6.x/5.7.x 'root' Privilege Escalation Vulnerability

این تاپیک جهت اطلاع رسانی مدیران سرور می باشد.
فیلم این باگ که جدید منتشر شده،در صورت استقبال در این تاپیک قرار میگیرد.

منبع : تیم امنیتی , تیم اکسپلویت , تیم تحقیقاتی , تیم هکری iedb.ir