تبلیغات در اینترنت

تبلیغات در اینترنتگیفت کارت گوگل پلی
صفحه 2 از 16 نخستنخست 12345678910111213141516 آخرینآخرین
نمایش نتایج: از 11 به 20 از 158

مقاله: رفع مشکل صفحات خالی یا "سفید" ویبولتین

    1. رفع مشکل صفحات خالی یا "سفید" ویبولتین »

      رفع مشکل صفحات خالی یا "سفید" ویبولتین

      نگارش: , by (مدیریت کل سایت)
      2011/07/15 03:16 PM
      امتیاز:  (5 رای ، میانگین : 4.60 )

      درود.

      اینجا دلایلی برای صفحات سفید یا خالی ویبولتین ارائه می کنیم :

      1. شما فایل های ویبولتین را به درستی آپلود نکرده اید . فایل های ویبولتین را ( بدون پوشه های حاوی تصویر / عکس ) را دوباره به سرور برگردانید ( در حالت ASCII ) و روی فایل های قبلی جایگزین ( Replace ) کنید .

      یا اینکه اگر ادمین سی پی شما باز نمیشود پوشه admincp را به admincp موجود در هاست برگردانید سپس از :

      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

      ادمین سی پی --> تعمیرات --> عیب شناسی --> بررسی فایل ها با نسخه ویبولتین

      فایل هائی را که باید تغییر کنند می بینید .

      2. مطمئن شوید که قبل از <?php و بعد از ?> در فایل config.php هیچ خط اضافی یا هیچ Spaceی وجود نداشته باشد .

      3. در صورتی که فقط صفحه اصلی شما باز نمیشود و مثلاً تاپیک های شما بدون مشکل باز می شوند شما یک index.htm یا index.html خالی درون روت انجمن دارید .

      4. شما یک پلاگین نصب کرده اید که این مشکل را بوجود آورده است . این آموزش را انجام دهید : آموزش غیر فعال کردن سیستم هک و پلاگین با Config.php

      نکته : اگر وی بی سئو نصب کرده اید برای غیر فعال کردن به پنل آن ( vbseocp.php ) بروید و آن را غیر فعال کنید و htaccess را از روت فروم خود حذف کنید.

      5. در فایل کانفیگ خود ( includes/config.php ) نام سرور را چک کنید . در اکثر موارد این قسمت مشکل دارد ( مخصوصاً در سرور های ویندوز و در هاست های رایگان ) :

      کد:
      $config['MasterServer']['servername'] = 'localhost';
      6. پی اچ پی شما magic_quotes_sybase را فعال کرده است . در صورتی که روی سرور های *nix هستید با اضافه کردن این خط به .htaccess میتوانید از آن جلوگیری کنید :

      کد:
      php_flag magic_quotes_sybase 0
      7. اگر شما تمامی صفحات را سفید میبینید به قالب Header یا Headinclude یا headinclude_bottom یا قالب های مشابه دیگر کدی را اضافه کردید .

      سریع ترین راه برای فهمیدن این که آیا این مشکل وجود دارد یا خیر این است که :

      Admin CP -> Styles & Templates -> Style Manager -> Add New Style

      ادمین سی پی --> استایل و قالب --> مدیریت استایل --> اضافه کردن استایل جدید

      بروید و یک استایل تازه بسازید ( که این استایل دیفالت خواهد بود ) . سپس آن را باز کنید ببینید درست میشود یا خیر . اگر درست شد مشکل شما از قالب هست . ( راستی تبلیغات رو هم چک کنید توش کد اضافی نزده باشید )

      8. به سی پنل / دایرکت ادمین هاست لاگین کنید و به phpmyadmin بروید . تیبل خود را از سمت جپ انتخاب کنید . از قسمت SQL کوئری زیر را ران کنید :

      کد:
      REPAIR TABLE template;
      9. شما جی زیپ را فعال کرده اید در صورتی که هاست شما آن را ساپورت نمیکند .

      Admin CP -> vBulletin Options -> Cookies and HTTP Header Options -> GZIP HTML Output -> No

      ادمین سی پی --> تنظیمات ---> تنظیمات اصلی انجمن --> تنظیمات کوکی و HTTP Header --> خروجی GZIP --> خیر


      اگر به ادمین سی پی دسترسی ندارید دو کوئری زیر را در دیتابیستان در phpmyadmin اجرا کنید .

      کد:
      UPDATE setting SET value = '0' WHERE varname = 'gzipoutput';
      کد:
      UPDATE datastore SET data=REPLACE(data,'s:10:"gzipoutput";i:1;','s:10:"gzipoutput";i:0;') WHERE title='options';
      یا فایل config.php خود را باز کنید و بعد از <?php یک Enter بزنید و این خط را قرار دهید :

      کد:
      DEFINE('NOZIP', 1);
      بعضی مواقع هم سرور این مورد را فعال کرده شما هم فعال کردید و پیج نمیتواند دوبار gzip شود پس باید شما غیر فعال کنید .

      10. بعضی مواقع نمایش ارور ( display_errors ) را هاست غیر فعال میکند ! پس شما بجای دیدن خطا یک صفحه سفید میبینید ! برای رفع این مشکل config.php خود را باز کنید بعد از <?php قرار دهید :

      کد:
      ini_set("display_errors", true);
      11. بعضی مواقع Suhosin بعنوان ماژول روی سرور نصب میشود . میتواند مشکل از همین باشد . در .htaccess خود خطوط زیر را اضافه کنید :

      کد:
      php_flag suhosin.cookie.encrypt Off
      php_value suhosin.request.max_vars 2048
      php_value suhosin.post.max_vars 2048
      12. میتواند باگ زیر باشد :

      http://bugs.php.net/bug.php?id=43620

      13. میتواند آنقدر مموری ( حافظه / استفاده از رم => memory_limit ) محدود شده باشد که ویبولتین نتواند اجرا شود ! برای جل وگیری از این مورد فایل config.php را باز کنید دقیقاً بعد از <?php این خط را قرار دهید :

      کد:
      ini_set('memory_limit', -1);
      14. برای تمامی گروه های کاربری بجز مدیران باید قسمت زیر را خیر بزنید :

      Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup -> Viewable on Show Groups

      ادمین سی پی --> گروه های کاربری --> مدیریت گروه های کاربری --> ویرایش گروه کاربری --> قابل نمایش در گروه های مدیران


      15. به پرمیشن ها ( chmod ) فایل ها توجه داشته باشید تمامی فولدر ها باید پرمیشن 0755 و تمامی فایل ها پرمیشن 0644 داشته باشند . اگر هر کدام به اشتباه روی 777 باشند میتواند یکی از دلایل سفید نمایش داده شدن صفحه باشد .

      16. فایل htaccess خود را چک کنید هر قوانین بازنویسی ( Rewrite rules ) میتواند باعث این مشکل شود .

      17 . در Php 3.5.2 باگی وجود دارد :

      http://bugs.php.net/bug.php?id=51425

      18 . اگر صفحه جستجوی شما سفید شده باید فایل criteria.php را باز کنید و در خط 836 کد زیر را

      کد:
      if (method_exists($this->search_type, 'get_display_name'))
      با کد زیر عوض کنید :

      کد:
      if (is_object($this->search_type) && is_callable($this->search_type->get_display_name()))
      موفق باشید .
  1. Top | #11
    مدیر بازنشته

    ورژن ویبولتین
    4.1.9
    نوشته ها
    3,995
    میزان امتیاز
    477

    پیش فرض

    سلام.من وي بي 4.1.5 دي جي تي رو نصب كردم.حالا فروم بالا مياد ولي صفحه مديريت يا ادمين سي پي بالا نمياد.بايد چيكار كنم دوستاااااااااااااان؟؟؟؟؟؟ ؟؟؟؟؟؟؟؟

    آدرس سايتم اينه : www.arashonline.ir/forum/admincp
    ارور دیتابیس دارید

    ربطی به صفحه ی سفید و این حرفا نیست ارورش ایمیلش میشه بهتون متنش رو قرار بدید بررسی میکنن دوستان




  2. گیفت کارت آیتونز

  3. Top | #12
    کاربر سایت

    ورژن ویبولتین
    4
    نوشته ها
    616
    میزان امتیاز
    77

    پیش فرض

    نقل قول نوشته اصلی توسط danyaltj نمایش پست ها
    ببين دوست من .براي نصب اين وي بي من اول اونو دانلود كردم.بعد اونو داخل پوشه فروم تو هاستم ايكستركت كردم.بعدش هم رفتم توي پوشه آپلود و بهد اينكلود و بعد اون فايل رو تبديل كردم و بعدش بازش كردم و مشخصات هاست رو ريختم داخلش.بعد مسير نصب رو طي كردم.و در آخر هم پوشه اينستال رو از داخل پوشه آپلود پاك كردم.حاتلا وقتي ميرم به آدرس سايتم مياد بالا ولي وقتي ميرم به آدرس ادمينم بالا نمياد.خواهشا بگو بايد چيكار كنم../؟؟؟؟؟؟؟؟؟؟؟؟؟؟؟
    با یه مرورگر و یا ترجیحا رو یه سیستم دیگه هم تستس کردی ؟ شاید گیر از سیستم یا مرروگرت باشه ؟

    کاربر مقابل از Coderx بابت این پست مفید تشکر کرده است:


  4. Top | #13
    کاربر سایت

    ورژن ویبولتین
    4.2.0
    نوشته ها
    685
    میزان امتیاز
    80

    پیش فرض

    سلام ....ببخشید منم مشکل ....باز نشدن admincp....رو دارم..باید چیکار کنم....یه صفحه صفید باز میشه از وی بی vBulletin.Forum.v4.1.8.PHP.NULL-FS

    استفاده میکنم....اینم آدرس صفحه ی ادمینمه...http://keriz.ir/forum/admincp/index.php
    ده بارم نصب کردم و پاک کردم...
    این دوستمونم danyaltj گفته بود همین مشکلو داره..

    چه جوری حل شده....کمکم کنید....خاهش...
    راستی....برا نصبشم....تا حالا نصب کردم مشکلی نداشته....ولی این دفه نمیدونم چرا اینجوری میشه...نصبش کامل شد....و فایل اینستالم پاک کردم...همین...
    ویرایش توسط abdollahpor : 2011/11/18 در ساعت 09:52 PM

  5. Top | #14
    مدیر بازنشته

    ورژن ویبولتین
    4.x
    نوشته ها
    3,437
    میزان امتیاز
    446

    پیش فرض

    نقل قول نوشته اصلی توسط abdollahpor نمایش پست ها
    سلام ....ببخشید منم مشکل ....باز نشدن admincp....رو دارم..باید چیکار کنم....یه صفحه صفید باز میشه از وی بی vBulletin.Forum.v4.1.8.PHP.NULL-FS

    استفاده میکنم....اینم آدرس صفحه ی ادمینمه...http://keriz.ir/forum/admincp/index.php
    ده بارم نصب کردم و پاک کردم...
    این دوستمونم danyaltj گفته بود همین مشکلو داره..

    چه جوری حل شده....کمکم کنید....خاهش...
    راستی....برا نصبشم....تا حالا نصب کردم مشکلی نداشته....ولی این دفه نمیدونم چرا اینجوری میشه...نصبش کامل شد....و فایل اینستالم پاک کردم...همین...
    با استفاده از فایل config.php ، همه ی هک ها رو غیر فعال کنید ، مشکلتون حل میشه .

    آموزش غیر فعال کردن هم تو سایت هست . . .


    با تشکر ،

    کاربر مقابل از OmidX بابت این پست مفید تشکر کرده است:


  6. Top | #15
    کاربر سایت

    ورژن ویبولتین
    4.2.0
    نوشته ها
    685
    میزان امتیاز
    80

    پیش فرض

    سلام...مرسی..من همین کارو کردم....واینجوری که توی این صفحه آموزش داده بودن آموزش غیر فعال کردن سیستم هک و پلاگین با Config.php عمل کردم ولی بازم وقتی میخام وارد ادمینم بشم همین صفحه باز میشه و درست نمیشه.....چیکار کنم

  7. Top | #16
    کاربر سایت

    ورژن ویبولتین
    4.2.0
    نوشته ها
    685
    میزان امتیاز
    80

    پیش فرض

    دوستان من همچنان گیر این صفحه خالیم ...کسی نیست.....خاهش کمک کنید...کسی....نمیدونه باید چیکار کنم.....

  8. Top | #17
    کاربر سایت

    ورژن ویبولتین
    4.2.0
    نوشته ها
    685
    میزان امتیاز
    80

    پیش فرض

    سلام دوستان کسی چیزی نمیخاد بگه من این صفحه سفیده هستم خاهش.....هر کاری میکنم نمیره....دوباره هم نصبش کردم......اون کد غیر فعال کردن هک هارو هم زدم ولی درست نشد بازم همون میاد.......

  9. Top | #18
    کاربر سایت

    ورژن ویبولتین
    4.06
    نوشته ها
    19
    میزان امتیاز
    0

    پیش فرض

    من هم مشکل دارم
    دسترسی به ادمین سی پی ندارم و فقط سفید نشون میده کلافه کننده است یکی بیاد کمکی بکنه !!! چرا هیچ کسی جواب گو نیست !!!

  10. Top | #19
    کاربر اخراجی

    ورژن ویبولتین
    4.13
    نوشته ها
    180
    میزان امتیاز
    0

    پیش فرض

    منم اين مشكل را دارم هر كس ميتونه كمكم كنه امروز اومدم فايل config را اديت كنم بعد فايل را دانلود كردم تو كامپيوترم و اون فايل ديگه روي هاست را پاك كردم و بعد فايللي كه دانلود كردم تو كامپيوترم را اپلود كردم الان هيچي نمياد بالا فقط يه صفحه سفيد مياد بالا چه كنم هر كي بده كمكم كنه الان تو پوشه includesرا اديت كنم ديگه نمياد بالا چيكار كنم هر كس بلده كمك كنه

  11. Top | #20
    کاربر سایت

    ورژن ویبولتین
    4.06
    نوشته ها
    19
    میزان امتیاز
    0

    پیش فرض

    سلام
    دوستان عزیز
    من این مشل رو داشتم ان شاالله با این چیزای که می گم مشکل شما هم هل بشه : شاید اون های که آپگرید هم میکنن این مشکل براشون پیش بیاد !
    مشکلاتی که من داشتم : بعد از آپگرید ادیمن سی پی بالا نمی اومد ! با نصب یه فروم به صورت جدا در یک مسیر دیگه توی پوشه دیگه ادمین سی پی بالا نمی اومد ولی فروم می اومد و از این اعصاب خورد کنی ها .......
    اول این رو بگم سایت من هک شده بودو چندین بار این طور شد : که از هاست بود و.......
    حالا من فکر میکردم شاید یه بک دور روی هاست مونده باشه و... کل فایل هام رو به اجیار پاک کردم ! و فقط دیتا بیش رو نگه داشتم ! نسخه قبلی مجدد ریختم رو هاست ( اکسترکت ) بعد از اون وارد کانفیگ شدم و اطلاعات دیتا بیس رو وارد کردم سایت بالا میاومد ! در این زمان کلیه هک ها رو غیر فعال کردم ( چون باز هم مشکوک بودم این ها رو هم حذف کردم ) .
    مجددا نسخه نهایی وی بی رو روی هاست اکسترکت کردم ! و در زمان نصب آپگریدش کردم ! بعد این مشکل من هل شد ! ولی قالب و... بهم ریختگی داشت که با سوال های که پرسیدم در این فروم بهم جواب دادن !!!!
    دوستان قبل هر کاری از کل اطلاعات هاست و دیتا بیستون بکاپ بگیرید و حتما ذخیره اش کنید !!!!!!!!!
    امید وارم موفق بشید !
    یا علی

    کاربر مقابل از NEGAHEFARDA بابت این پست مفید تشکر کرده است:


اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کسانی که این مقاله را دیده اند از این مقاله ها نیز بازدید کرده اند

  1. پاسخ: 17
    آخرين نوشته: 2013/09/10, 11:41 AM
  2. پاسخ: 24
    آخرين نوشته: 2012/06/02, 12:27 AM
  3. پاسخ: 11
    آخرين نوشته: 2012/01/24, 10:43 AM
  4. تاپیک ویژه | "انجمن" خود را سریع کنید ! ویبولتین 4
    توسط VBIran در انجمن آموزش های وی بولتین
    پاسخ: 4
    آخرين نوشته: 2011/04/18, 09:52 AM

کلمات کلیدی این موضوع

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •