تبلیغات در اینترنتتبلیغات در اینترنت
نمایش نتایج: از 1 به 8 از 8

موضوع: مشکل زبان بعد از اپگرید به 4.2.5

  1. Top | #1
    کاربر سایت

    تاریخ عضویت
    Sep 2013
    ورژن ویبولتین
    4.1.2
    سن
    90
    نوشته ها
    107
    مورد پسند
    32 بار
    اطلاعات
    Windows NT 10.0 Firefox 58.0
    میزان امتیاز
    15

    Post مشکل زبان بعد از اپگرید به 4.2.5

    درود

    من انجمن رو از 4.2.3 به ورژن 4.2.5 آپگرید کردم

    بعد از اتمام کلا حروف رو درست نشون نمیده .

    دیتابیس هم قسمت charsets روی utf8mb4_unicode_ci هست

    فارسی ساز رو ریختم ، ولی پست ها و نام تالار ها و ... همچنان به شکل زیر است :




    آدرس : یکتا کر | مرجع رایگان ساخت گیم سرورWow در ایران

    ورژن PHP : 5.6

    ورژن MySQL : 5.5




  2. گیفت کارت آیتونز

  3. Top | #2
    مدیر ارشد

    تاریخ عضویت
    Aug 2014
    ورژن ویبولتین
    4
    سن
    23
    نوشته ها
    4,178
    مورد پسند
    3,108 بار
    نوشته های وبلاگ
    17
    اطلاعات
    Linux Chrome 64.0.3282.119
    میزان امتیاز
    503

    پیش فرض

    بکاپ قبلی رو ریستور کنید
    از داخل ادمین سی پی، تمامی زبان ها رو پاک کنید و تنها بذارید زبان اصلی انگلیسی باقی بمونه (گزینه تعمیر زبان ها رو از همون بخش زبان ها بزنید)
    الان فقط باید زبان انگلیسی داشته باشید
    حالا آپگرید کنید و بعدش زبان فارسی رو اضافه کنید
    ببینید مشکل حل میشه یا خیر

    یا هم یک بار بدون ریستور کردن امتحان کنید:
    اگر زبان انگلیسی رو حذف نکردید، سایت رو به زبان انگلیسی کنید
    بعد یک زبان فارسی جدید نصب کنید (نیازی به حذف زبان فارسی فعلی نیست)

    ببینید هیچ یک از این دو راه نتیجه میدن یا خیر.

    کاربر مقابل از Inna بابت این پست مفید تشکر کرده است:


  4. Top | #3
    کاربر سایت

    تاریخ عضویت
    Sep 2013
    ورژن ویبولتین
    4.1.2
    سن
    90
    نوشته ها
    107
    مورد پسند
    32 بار
    اطلاعات
    Windows NT 10.0 Firefox 58.0
    میزان امتیاز
    15

    پیش فرض

    نقل قول نوشته اصلی توسط Inna نمایش پست ها
    بکاپ قبلی رو ریستور کنید
    از داخل ادمین سی پی، تمامی زبان ها رو پاک کنید و تنها بذارید زبان اصلی انگلیسی باقی بمونه (گزینه تعمیر زبان ها رو از همون بخش زبان ها بزنید)
    الان فقط باید زبان انگلیسی داشته باشید
    حالا آپگرید کنید و بعدش زبان فارسی رو اضافه کنید
    ببینید مشکل حل میشه یا خیر

    یا هم یک بار بدون ریستور کردن امتحان کنید:
    اگر زبان انگلیسی رو حذف نکردید، سایت رو به زبان انگلیسی کنید
    بعد یک زبان فارسی جدید نصب کنید (نیازی به حذف زبان فارسی فعلی نیست)

    ببینید هیچ یک از این دو راه نتیجه میدن یا خیر.
    اصلا بحث زبان Translate نیست . پست ها و نام تالار ها و ... که خودم وارد کردم این شکلیه . روش اول همینه که الان میبینید .

    روش دوم هم تست شد الان ، تفاوتی نکرد . با چیزی که شما میگید فقط زبان متن های ترجمه شده خود فروم درست میشه ، پست و ... هیچ تغییری نمیکنند .

  5. Top | #4
    مدیر ارشد

    تاریخ عضویت
    Aug 2014
    ورژن ویبولتین
    4
    سن
    23
    نوشته ها
    4,178
    مورد پسند
    3,108 بار
    نوشته های وبلاگ
    17
    اطلاعات
    Linux Chrome 64.0.3282.119
    میزان امتیاز
    503

    پیش فرض

    نسخه سوئیت دارید یا فروم؟
    یعنی cms و blog هم دارید؟

  6. Top | #5
    کاربر سایت

    تاریخ عضویت
    Sep 2013
    ورژن ویبولتین
    4.1.2
    سن
    90
    نوشته ها
    107
    مورد پسند
    32 بار
    اطلاعات
    Windows NT 10.0 Firefox 58.0
    میزان امتیاز
    15

    پیش فرض

    نقل قول نوشته اصلی توسط Inna نمایش پست ها
    نسخه سوئیت دارید یا فروم؟
    یعنی cms و blog هم دارید؟
    سوئیت هست ولی CMS و Blog رو حذف کردم ، هم توی ورژن قبل هم در ورژن جدید .

  7. Top | #6
    مدیر ارشد

    تاریخ عضویت
    Aug 2014
    ورژن ویبولتین
    4
    سن
    23
    نوشته ها
    4,178
    مورد پسند
    3,108 بار
    نوشته های وبلاگ
    17
    اطلاعات
    Linux Chrome 64.0.3282.140
    میزان امتیاز
    503

    پیش فرض

    ممکن هست دسترسی هاست+ادمین سی پی رو از طریق خصوصی یا تلگرام ارسال کنید؟

  8. Top | #7
    کاربر سایت

    تاریخ عضویت
    Sep 2013
    ورژن ویبولتین
    4.1.2
    سن
    90
    نوشته ها
    107
    مورد پسند
    32 بار
    اطلاعات
    Windows NT 10.0 Firefox 58.0
    میزان امتیاز
    15

    پیش فرض

    مشکل رفع شد .

    راه حل : اگر charsets اطلاعات دیتابیس شما روی utf8mb4_unicode_ci بود و بعد از آپدیت ورژن PHP به این شکل در اومد ، به Config.php رفته و دنبال متن زیر بگردید:

    کد:
    // $config['Mysqli']['charset'] = 'utf8';
    // که اول خط هست رو پاک کنید و utf8 رو به latin1 تغییر دهید .


    پست بسته شود .

  9. Top | #8
    مدیر ارشد

    تاریخ عضویت
    Aug 2014
    ورژن ویبولتین
    4
    سن
    23
    نوشته ها
    4,178
    مورد پسند
    3,108 بار
    نوشته های وبلاگ
    17
    اطلاعات
    Windows NT 10.0 Chrome 63.0.3239.132
    میزان امتیاز
    503

    پیش فرض

    بسته شد

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کلمات کلیدی این موضوع

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •