تبلیغات در اینترنت

تبلیغات در اینترنتگیفت کارت گوگل پلی
نمایش نتایج: از 1 به 3 از 3

موضوع: راه حل ارور functions_wysiwyg.php

  1. Top | #1
    کاربر ویژه

    تاریخ عضویت
    Sep 2010
    ورژن ویبولتین
    3.8.6
    نوشته ها
    51
    مورد پسند
    33 بار
    اطلاعات
    میزان امتیاز
    12

    پیش فرض

    سلام
    یه هکی رو من اضافه کردم که با استفاده از cron کار میکنه زمانیکه اجراش میکنم ارور مربوط به این فایل رو میده
    تو آدرس زیر یه مقاله هست که چگونگی برطرف کردن این مشکل رو نوشته:
    http://www.vbulletin.org/forum/showthread.php?p=2221551

    یه قسمتش فقط برای افرادی که لیسانس دارن قابل مشاهده هست
    از دوستان اگر کسی لیسانس داره خواهش میکنم متن کامل + اگر فایلی هست رو اینجا بذاره
    ممنون

    پیدا کردم
    تو ورژن 4.1.4 که دانلود کردم این فایل نبود از ورژن 3.8.6 که قبلاً داشتم کپی کردم الان مشکلم حل شد
    ویرایش توسط YashaR : 2011/07/26 در ساعت 12:05 AM دلیل: ادغام دو پست
    ...




  2. گیفت کارت آیتونز

  3. Top | #2
    مدیریت کل سایت

    تاریخ عضویت
    Aug 2009
    ورژن ویبولتین
    4.2.2
    نوشته ها
    21,685
    مورد پسند
    54,811 بار
    نوشته های وبلاگ
    14
    اطلاعات
    میزان امتیاز
    3117

    پیش فرض

    How to fix functions_wysiwyg.php errors (Article)

    Hello all,

    After loosing the coder's title, I can't post any more in Articles section, so I'm posting here a fix, for those who have developed addon modules (using the vbEditor only), and the new 4.1.4 version brought to them error:

    Warning: require_once(./includes/functions_wysiwyg.php) [function.require-once]: failed to open stream

    This error appear to all new 4.1.4 installations, but for those who have upgraded from 4.1.3, it can appears or not. It has nothing to do with server configurations. It has to do with your choice during upgrade to delete or not the old unused files. Among those files is the: functions_wysiwyg.php which is not in use anymore.

    If you choosen to keep the old files, your module will continue working, but (in my opinion), is a security risk to let in your site files that are not any more in vB's file structure and thus are not checked for bugs any more.

    To make your addon compatible with 4.1.4, but still keep compatiblity with previous versions (not all have upgraded to 4.1.4 yet), here are the changes that you need to do:

    1.- Fing the section where your code was getting the value of the posting message and change it to:
    Code:

    if (version_compare(@$vbulletin->versionnumber, '4.1.4', '>=')) { require_once(DIR . '/includes/class_wysiwygparser.php'); $html_parser = new vB_WysiwygHtmlParser($vbulletin); $vbulletin->GPC['message'] = $html_parser->parse_wysiwyg_html_to_bbcode($_POST['message'], 0); } else { require_once(DIR . '/includes/functions_wysiwyg.php'); $vbulletin->GPC['message'] = convert_wysiwyg_html_to_bbcode($_POST['message'], 0); }
    2.- Be sure that there is no any call to functions_wysiwyg.php at the top of your file. Usally coders add it at the top of the file with other includes (eg global.php). If you find any call to functions_wysiwyg.php follow the step 1.

    3.- Of course there is another way to fix the problem, but I don't really suggest it. Just in case that you can't fix it. Find the files of any vB version prior to 4.1.4 and copy the file functions_wysiwyg.php which you can find inside the includes directory. vB4.1.4 does has this file in the package.

    Maria

    2 تشکر توسط:


  4. Top | #3
    کاربر سایت

    تاریخ عضویت
    Mar 2012
    ورژن ویبولتین
    با افتخار 4.1.5
    نوشته ها
    542
    مورد پسند
    367 بار
    اطلاعات
    Windows 8 Firefox 32.0
    میزان امتیاز
    66

    پیش فرض

    نقل قول نوشته اصلی توسط VBIran نمایش پست ها
    How to fix functions_wysiwyg.php errors (Article)

    Hello all,

    After loosing the coder's title, I can't post any more in Articles section, so I'm posting here a fix, for those who have developed addon modules (using the vbEditor only), and the new 4.1.4 version brought to them error:

    Warning: require_once(./includes/functions_wysiwyg.php) [function.require-once]: failed to open stream

    This error appear to all new 4.1.4 installations, but for those who have upgraded from 4.1.3, it can appears or not. It has nothing to do with server configurations. It has to do with your choice during upgrade to delete or not the old unused files. Among those files is the: functions_wysiwyg.php which is not in use anymore.

    If you choosen to keep the old files, your module will continue working, but (in my opinion), is a security risk to let in your site files that are not any more in vB's file structure and thus are not checked for bugs any more.

    To make your addon compatible with 4.1.4, but still keep compatiblity with previous versions (not all have upgraded to 4.1.4 yet), here are the changes that you need to do:

    1.- Fing the section where your code was getting the value of the posting message and change it to:
    Code:

    if (version_compare(@$vbulletin->versionnumber, '4.1.4', '>=')) { require_once(DIR . '/includes/class_wysiwygparser.php'); $html_parser = new vB_WysiwygHtmlParser($vbulletin); $vbulletin->GPC['message'] = $html_parser->parse_wysiwyg_html_to_bbcode($_POST['message'], 0); } else { require_once(DIR . '/includes/functions_wysiwyg.php'); $vbulletin->GPC['message'] = convert_wysiwyg_html_to_bbcode($_POST['message'], 0); }
    2.- Be sure that there is no any call to functions_wysiwyg.php at the top of your file. Usally coders add it at the top of the file with other includes (eg global.php). If you find any call to functions_wysiwyg.php follow the step 1.

    3.- Of course there is another way to fix the problem, but I don't really suggest it. Just in case that you can't fix it. Find the files of any vB version prior to 4.1.4 and copy the file functions_wysiwyg.php which you can find inside the includes directory. vB4.1.4 does has this file in the package.

    Maria

    درود

    اول عذر بخاطر آپ کردن پست قدیمی

    دوم اینکه من جدیداً با این مشکل برخوردم، اینجا هم مطرح کردم ولی هنوز پاسخی نگرفتم

    میشه یه راهنمائی/ترجمه مختصر بکنید برای حل این مشکل؟
    ســـالهاست که از خود گذشته‌ام .... یــــادم بخیــــــــــر

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کلمات کلیدی این موضوع

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •